April 16, 2014, 09:26:52 AM

collapse

* Sponsors


* Hot Topics


* Facebook Like


* Sponsors


* Board Stats

  • stats Total Members: 1215
  • stats Total Posts: 6353
  • stats Total Topics: 980
  • stats Total Categories: 3
  • stats Total Boards: 17
  • stats Most Online: 164

Author Topic: Cannot apply OTA3 on my Rooted US device  (Read 4471 times)

sonex293

  • Newbie
  • *
  • Posts: 18
    • View Profile
Cannot apply OTA3 on my Rooted US device
« on: June 26, 2012, 11:57:52 AM »
I have rooted my TPT, but have otherwise not made any changes.  I have used Rootkeeper to remove root access.

First the automatic update failed, so I obtained the manual update files and tried to update.  Both failed with the following messages...

Assert failed: apply_patch_check("/system/app/jaba_signed.apk","0ba9f515fc618be856707e6b0e36339aaeabac9b", "01beff38f83780d01d9e4fc3abadd2c4f53d46f8")
E:Error in /cache/update.zip
(Status 7)
Installation aborted.

I have checked the check-sum of the jaba_signed.apk for both the installed version on my TPT and the one from update ThinkPadTablet_A310_02_0024_0065_US and they are the same.  I don't see an updated version being installed since then....

Any ideas?

==
Michael

 

sonex293

  • Newbie
  • *
  • Posts: 18
    • View Profile
Re: Cannot apply OTA3 on my Rooted US device
« Reply #1 on: June 26, 2012, 04:25:23 PM »
Success!

I got both files (jaba_signed.apk and busybox) from the file ThinkPadTablet_A310_02_0039_0089_ROW.zip linked above.

The jaba_signed.apk file goes in the /system/app directory and the busybox file goes in the /system/xbin directory.

I had to use ES Explorer and root to replace the files.   Then I temporarily removed root with "RootKeeper" and installed the update manually.  There were two files on the old website that have since been removed,

1. ThinkPadTablet_A310_03_0069_0130_US.zip
2. ThinkPadTablet_A400_03_0069_0130_US.zip

I only installed the first one, but when I go to "About Tablet" in settings it says the build number is now ThinkPadTablet_A400_03_0069_0130_US, so I didn't installing the second file?

I've spent the last hour making folders of my applications on the main screen.  A BIG advantage over Honeycomb are the folders!

--
Michael

GodfatherIP

  • Full Member
  • ***
  • Posts: 167
    • View Profile
Re: Cannot apply OTA3 on my Rooted US device
« Reply #2 on: June 26, 2012, 07:14:10 PM »
I installed both, first big one then little one.  You should probably go ahead an update with the small file to make sure everything on your tablet is up to date.

xi slick ix

  • Jr. Member
  • **
  • Posts: 62
    • View Profile
Re: Cannot apply OTA3 on my Rooted US device
« Reply #3 on: June 26, 2012, 09:27:26 PM »
I'm experiencing similar problems on my tablet.. When you said the files were pulled from their site, are they still currently pulled, and if they are, do you have them by chance?

Sent from my ADR6300 using Tapatalk 2


BoraVR6

  • Newbie
  • *
  • Posts: 9
    • View Profile
Re: Cannot apply OTA3 on my Rooted US device
« Reply #5 on: June 26, 2012, 10:11:49 PM »
Hi,


I add to the persons who aren't able to upgrade to ICS in a US_rooted TPT.

My steps until now!

1.-Backup
2.- Vodoo for unroot  (plus no CWM running on my TPT)
3.- OTA always try to update, and keep checking and checking for updates!
4.- Entering in ANDROID SYSTEM RECOVERY
5.- WIPING CACHE
6.-  Apply update from external SD Storage; whatever be the file used from the 2 different files for ICS_US, the  result is the same.
7.- ERROR MESSAGE:



Verifying current system...
assert failed: apply_patch_check("/system/bin/wpa_supplicant", "a95d16b5df6c56868f06826a958a7067b0542fd2", "6cb156b7e3f38fae0fd45f76a27ccb04556bb8f3")
E:Error in /tmp/sideload/package.zip
(Status 7)

Installation aborted.



Regards.

ker2

  • Full Member
  • ***
  • Posts: 206
    • View Profile
Re: Re: Cannot apply OTA3 on my Rooted US device
« Reply #6 on: June 26, 2012, 10:24:41 PM »
Hi,


I add to the persons who aren't able to upgrade to ICS in a US_rooted TPT.

My steps until now!

1.-Backup
2.- Vodoo for unroot  (plus no CWM running on my TPT)
3.- OTA always try to update, and keep checking and checking for updates!
4.- Entering in ANDROID SYSTEM RECOVERY
5.- WIPING CACHE
6.-  Apply update from external SD Storage; whatever be the file used from the 2 different files for ICS_US, the  result is the same.
7.- ERROR MESSAGE:



Verifying current system...
assert failed: apply_patch_check("/system/bin/wpa_supplicant", "a95d16b5df6c56868f06826a958a7067b0542fd2", "6cb156b7e3f38fae0fd45f76a27ccb04556bb8f3")
E:Error in /tmp/sideload/package.zip
(Status 7)

Installation aborted.



Regards.
i had better luck from system update screen and automatically install the update thats how i avoided the E:Error in /tmp/sideload/package.zip check your system/bin for a file wpa_supplicant if missing get it from a zip file and put it back then do check system update and download and do auto install

rocking rooted ics ThinkPadTablet..... bitches

GodfatherIP

  • Full Member
  • ***
  • Posts: 167
    • View Profile
Re: Cannot apply OTA3 on my Rooted US device
« Reply #7 on: June 27, 2012, 11:16:11 AM »
Hi,


I add to the persons who aren't able to upgrade to ICS in a US_rooted TPT.

My steps until now!

1.-Backup
2.- Vodoo for unroot  (plus no CWM running on my TPT)
3.- OTA always try to update, and keep checking and checking for updates!
4.- Entering in ANDROID SYSTEM RECOVERY
5.- WIPING CACHE
6.-  Apply update from external SD Storage; whatever be the file used from the 2 different files for ICS_US, the  result is the same.
7.- ERROR MESSAGE:



Verifying current system...
assert failed: apply_patch_check("/system/bin/wpa_supplicant", "a95d16b5df6c56868f06826a958a7067b0542fd2", "6cb156b7e3f38fae0fd45f76a27ccb04556bb8f3")
E:Error in /tmp/sideload/package.zip
(Status 7)

Installation aborted.



Regards.

You have a modified wpa_supplicant file.  If you did not make a backup of the original I think I have a backup of the original wpa_supplicant for US tablets that I can give you.

coyttl

  • Jr. Member
  • **
  • Posts: 97
  • Causing small squirrels to commit suicide!
    • View Profile
Re: Cannot apply OTA3 on my Rooted US device
« Reply #8 on: June 27, 2012, 01:43:37 PM »
You have a modified wpa_supplicant file.  If you did not make a backup of the original I think I have a backup of the original wpa_supplicant for US tablets that I can give you.
If you have it, it'd be appreciated. I didn't get a nandroid backup before I got your nandorid backup and VWM installed, and apparently my wpa_supplicant is hosed as well.

My offer for hosting all these files for easy download still stands, if anyone's interested.  :-*

BoraVR6

  • Newbie
  • *
  • Posts: 9
    • View Profile
Re: Cannot apply OTA3 on my Rooted US device
« Reply #9 on: June 27, 2012, 01:50:03 PM »
Hi,

Thanks, wpa_supplicant solved by deleting ad-hoc WiFi enabler.

For the moment I'm stuck on the   BUSY BOX issue.
I need to found some way to connect pc for similar procees to root and see if I can copy Busybox for the original one.
Or found sme other way,until nowmo luckyfor replace BUSYBOX, by permissions issue.

pixbuf

  • Newbie
  • *
  • Posts: 28
    • View Profile
Re: Cannot apply OTA3 on my Rooted US device
« Reply #10 on: June 27, 2012, 09:17:37 PM »
Now I totally screwed the pooch. I followed GodfatherIP's instructions in this post
http://www.thinkpadtabletforums.com/thinkpad-tablet-root-hacks-mods-and-development/ota2-us-released/msg3740/#msg3740
In updater-script, I removed the assert(getprop()) that referred to Indigo, removed the certificate files, rezipped the file, and resigned it using the method here:
http://fokke.org/site/content/howto-create-android-updatezip-package
Tried to flash it. It passes the initial checks that it failed at before, removes old files, starts patching system files and then spontaneously reboots into recovery. Same thing over and over.

Can't get it to boot normally, either. Any ideas on how to proceed, or should I just throw the thing away?  :-\

pghFL

  • Sr. Member
  • ****
  • Posts: 495
    • View Profile
Re: Cannot apply OTA3 on my Rooted US device
« Reply #11 on: June 28, 2012, 01:59:18 AM »
Now I totally screwed the pooch...

...Can't get it to boot normally, either. Any ideas on how to proceed, or should I just throw the thing away?  :-\

If GodfatherIP can't help (he probably can), send it to  Lenovo for motherboard replacement. Don't mention having root. I think there's nothing else they can do but replace the board.
Don't get mad, get root
GNote N8013
183827U 64GB
0089_US/Root/CWM ;D

strongbowsix

  • Newbie
  • *
  • Posts: 7
    • View Profile
Re: Cannot apply OTA3 on my Rooted US device
« Reply #12 on: June 28, 2012, 06:39:12 AM »
hello!
having same issue. Does anyone have the original googlefeedback.apk? that is the one check failing for me now. Thanks!

EDIT: went to the lenovo site that has prior images and pulled googlefeedback.apk file from an older version.  Still didn't work...

Considering doing a factory reset, but hoping not to.

EDIT2: OMG. How painful.  Did a factory reset and tried to apply update and am still getting the same error.  How disappointing... :-[  Not only do I not have ICS, all of my stuff is gone to...  I am getting the above failed assert check of the googlefeedback.apk.  Not sure what I should do now.  Any help is appreciated.

Tried to install manually and get the assert failed: file_getprop("/system build.prop".
"ro.build.fingerprint.prop",  etc. etc.  then E:Error in /tmp/sideload/package.zip

EDIT3:

GOOD NEWS!  Went through a factory reset for nothing!  in the ICS Upgrade Thread by Jortega, GodfatherIP has a system.zip file with all the orginial apks.  Using rootexplorer went through the automatic update and noted each error in apk. after each replacement temp unrooted and then ran automatic update.  Finally upgraded to ICS!!!  Now time to restore all the aps.  Better than having to send in for service though! :)  Hope this helps someone that is frustrated!
« Last Edit: June 28, 2012, 10:22:44 AM by strongbowsix »

pixbuf

  • Newbie
  • *
  • Posts: 28
    • View Profile
Re: Cannot apply OTA3 on my Rooted US device
« Reply #13 on: June 28, 2012, 07:47:36 PM »
Now I totally screwed the pooch...

...Can't get it to boot normally, either. Any ideas on how to proceed, or should I just throw the thing away?  :-\

If GodfatherIP can't help (he probably can), send it to  Lenovo for motherboard replacement. Don't mention having root. I think there's nothing else they can do but replace the board.

I realized that I had an old Nandroid backup. I restored that and now I'm up and running again. Whew!

pixbuf

  • Newbie
  • *
  • Posts: 28
    • View Profile
Re: Cannot apply OTA3 on my Rooted US device
« Reply #14 on: June 28, 2012, 08:10:43 PM »
My Nandroid backup restore brought me back to 0075. I installed 0086 and then 0089, and did another Nandroid backup. Then I tried flashing ThinkPadTablet_A310_03_0069_0130_US.zip in CWM but I got the ro.product.device=="Indigo" error again. The weird thing is that I have the line ro.product.device=Indigo in my build.prop. How do you get around this?

 




SimplePortal 2.3.3 © 2008-2010, SimplePortal